#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[0-9+][0-9 ]{6,}[0-9]"
Local $sString = "0904123456" & @CRLF & _
"0904 123 456" & @CRLF & _
"+421 904123456" & @CRLF & _
"+421 904 123 456" & @CRLF & _
"+421 904 12 34 56" & @CRLF & _
"0 9 0 4 1 2 3 4 5 6"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")