import re
regex = re.compile(r"[0-9+][0-9 ]{6,}[0-9]", flags=re.MULTILINE)
test_str = ("0904123456\n"
"0904 123 456\n"
"+421 904123456\n"
"+421 904 123 456\n"
"+421 904 12 34 56\n"
"0 9 0 4 1 2 3 4 5 6")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")