$re = '/[0-9+][0-9 ]{6,}[0-9]/m';
$str = '0904123456
0904 123 456
+421 904123456
+421 904 123 456
+421 904 12 34 56
0 9 0 4 1 2 3 4 5 6';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);