// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[0-9+][0-9 ]{6,}[0-9]").unwrap();
let string = "0904123456
0904 123 456
+421 904123456
+421 904 123 456
+421 904 12 34 56
0 9 0 4 1 2 3 4 5 6";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}