import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[0-9+][0-9 ]{6,}[0-9]";
final String string = "0904123456\n"
+ "0904 123 456\n"
+ "+421 904123456\n"
+ "+421 904 123 456\n"
+ "+421 904 12 34 56\n"
+ "0 9 0 4 1 2 3 4 5 6";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}