using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"['’]s\b|[^[:alnum:][:blank:]@_]";
string substitution = @"";
string input = @"@kyrieirving’s";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}