use strict;
my $str = '@kyrieirving’s';
my $regex = qr/['’]s\b|[^[:alnum:][:blank:]@_]/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";