$re = '/[\'’]s\b|[^[:alnum:][:blank:]@_]/m';
$str = '@kyrieirving’s';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;