re = /['’]s\b|[^[:alnum:][:blank:]@_]/m
str = '@kyrieirving’s'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result