const regex = /['’]s\b|[^[:alnum:][:blank:]@_]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\'’]s\\b|[^[:alnum:][:blank:]@_]', 'gm')
const str = `@kyrieirving’s`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);