use strict;
my $str = 'INTEGER 15digits
0
1
-1
12
-12
123456789012345
-123456789012345
INVALID
01
-01
1234567890123456
-1234567890123456
.123456
-.123456
0.
-0.
1234567890123456789012
-1234567890123456789012
12345678901234567890.1
-12345678901234567890.1
FLOAT (...)
0.1234567890123456789
-0.1234567890123456789
1.1234567890123456789
-1.1234567890123456789
12.123456789012345678
-12.123456789012345678
1234567890123456789.1
-1234567890123456789.1
';
my $regex = qr/^(0|-?0\.\d+|-?[1-9]\d{0,14}|-?[1-9]\d{0,18}\.\d+)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}