import Foundation
let pattern = #"^(0|-?0\.\d+|-?[1-9]\d{0,14}|-?[1-9]\d{0,18}\.\d+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
INTEGER 15digits
0
1
-1
12
-12
123456789012345
-123456789012345
INVALID
01
-01
1234567890123456
-1234567890123456
.123456
-.123456
0.
-0.
1234567890123456789012
-1234567890123456789012
12345678901234567890.1
-12345678901234567890.1
FLOAT (...)
0.1234567890123456789
-0.1234567890123456789
1.1234567890123456789
-1.1234567890123456789
12.123456789012345678
-12.123456789012345678
1234567890123456789.1
-1234567890123456789.1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)