$re = '/^(0|-?0\.\d+|-?[1-9]\d{0,14}|-?[1-9]\d{0,18}\.\d+)$/m';
$str = 'INTEGER 15digits
0
1
-1
12
-12
123456789012345
-123456789012345
INVALID
01
-01
1234567890123456
-1234567890123456
.123456
-.123456
0.
-0.
1234567890123456789012
-1234567890123456789012
12345678901234567890.1
-12345678901234567890.1
FLOAT (...)
0.1234567890123456789
-0.1234567890123456789
1.1234567890123456789
-1.1234567890123456789
12.123456789012345678
-12.123456789012345678
1234567890123456789.1
-1234567890123456789.1
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);