# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(0|-?0\.\d+|-?[1-9]\d{0,14}|-?[1-9]\d{0,18}\.\d+)$"
test_str = ("INTEGER 15digits\n"
"0\n"
"1\n"
"-1\n"
"12\n"
"-12\n"
"123456789012345\n"
"-123456789012345\n\n"
"INVALID\n"
"01\n"
"-01\n"
"1234567890123456\n"
"-1234567890123456\n"
".123456\n"
"-.123456\n"
"0.\n"
"-0.\n"
"1234567890123456789012\n"
"-1234567890123456789012\n"
"12345678901234567890.1\n"
"-12345678901234567890.1\n\n"
"FLOAT (...)\n"
"0.1234567890123456789\n"
"-0.1234567890123456789\n"
"1.1234567890123456789\n"
"-1.1234567890123456789\n"
"12.123456789012345678\n"
"-12.123456789012345678\n"
"1234567890123456789.1\n"
"-1234567890123456789.1\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.