#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = " a(?= )"
Local $sString = "x a y a x" & @CRLF & _
"x a a a x" & @CRLF & _
"x aa x"
Local $sSubst = " b"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)