use strict;
my $str = 'x a y a x
x a a a x
x aa x';
my $regex = qr/ a(?= )/p;
my $subst = ' b';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";