import Foundation
let pattern = #" a(?= )"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
x a y a x
x a a a x
x aa x
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" b"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)