using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" a(?= )";
string substitution = @" b";
string input = @"x a y a x
x a a a x
x aa x";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}