import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*(.{0,23}\\S)(?:\\s+(.{0,29}\\S))?\\s*$";
final String string = " 1 Apple Park Way. Cupertino, CA 95014 \n\n"
+ "1600 Amphitheatre Parkway Mountain View, CA 94043\n\n"
+ "123456789012345678901234567890123456789012345678901234\n\n"
+ "123456789012345678901234\n\n"
+ "12345678901234 123456789012345678901234567890";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}