re = /^\s*(.{0,23}\S)(?:\s+(.{0,29}\S))?\s*$/m
str = ' 1 Apple Park Way. Cupertino, CA 95014
1600 Amphitheatre Parkway Mountain View, CA 94043
123456789012345678901234567890123456789012345678901234
123456789012345678901234
12345678901234 123456789012345678901234567890'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end