using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<={{(?:(?!}}|{{).)*\|(?:(?!}}|{{).)*)\bString\b(?=(?:(?!}}|{{).)*}})|\bString\b(?!(?<={{(?:(?!}}).)*)(?:(?!{{).)*}})";
string input = @"1 {{String Text|String}}
1 {{|Text String 1}}
1 {{|String}}
1 {{Te|xt String}}
2 String {{String}} String
3 String String Strings String{{String}}
2 {{String| Text||||String }String|Hmm}}
1 {String}}
1 {{String}
0 {{Strink}}
0 {{{String}}}
4 String {{{{A|String}} String {{A String}}}} String";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}