const regex = new RegExp('(?<={{(?:(?!}}|{{).)*\\|(?:(?!}}|{{).)*)\\bString\\b(?=(?:(?!}}|{{).)*}})|\\bString\\b(?!(?<={{(?:(?!}}).)*)(?:(?!{{).)*}})', 'gm')
const str = `1 {{String Text|String}}
1 {{|Text String 1}}
1 {{|String}}
1 {{Te|xt String}}
2 String {{String}} String
3 String String Strings String{{String}}
2 {{String| Text||||String }String|Hmm}}
1 {String}}
1 {{String}
0 {{Strink}}
0 {{{String}}}
4 String {{{{A|String}} String {{A String}}}} String`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}