re = /(?<={{(?:(?!}}|{{).)*\|(?:(?!}}|{{).)*)\bString\b(?=(?:(?!}}|{{).)*}})|\bString\b(?!(?<={{(?:(?!}}).)*)(?:(?!{{).)*}})/m
str = '1 {{String Text|String}}
1 {{|Text String 1}}
1 {{|String}}
1 {{Te|xt String}}
2 String {{String}} String
3 String String Strings String{{String}}
2 {{String| Text||||String }String|Hmm}}
1 {String}}
1 {{String}
0 {{Strink}}
0 {{{String}}}
4 String {{{{A|String}} String {{A String}}}} String'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end