use strict;
my $str = '1 {{String Text|String}}
1 {{|Text String 1}}
1 {{|String}}
1 {{Te|xt String}}
2 String {{String}} String
3 String String Strings String{{String}}
2 {{String| Text||||String }String|Hmm}}
1 {String}}
1 {{String}
0 {{Strink}}
0 {{{String}}}
4 String {{{{A|String}} String {{A String}}}} String';
my $regex = qr/(?<={{(?:(?!}}|{{).)*\|(?:(?!}}|{{).)*)\bString\b(?=(?:(?!}}|{{).)*}})|\bString\b(?!(?<={{(?:(?!}}).)*)(?:(?!{{).)*}})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}