import re
regex = re.compile(r"(?<={{(?:(?!}}|{{).)*\|(?:(?!}}|{{).)*)\bString\b(?=(?:(?!}}|{{).)*}})|\bString\b(?!(?<={{(?:(?!}}).)*)(?:(?!{{).)*}})", flags=re.MULTILINE)
test_str = ("1 {{String Text|String}}\n"
"1 {{|Text String 1}}\n"
"1 {{|String}}\n"
"1 {{Te|xt String}}\n"
"2 String {{String}} String\n"
"3 String String Strings String{{String}}\n"
"2 {{String| Text||||String }String|Hmm}}\n"
"1 {String}}\n"
"1 {{String}\n"
"0 {{Strink}}\n"
"0 {{{String}}}\n"
"4 String {{{{A|String}} String {{A String}}}} String")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")