package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(C3-)(\d)$`)
var str = `C3-1`
var substitution = "\g<1>000\2"
fmt.Println(re.ReplaceAllString(str, substitution))
}