use strict;
my $str = 'C3-1';
my $regex = qr/^(C3-)(\d)$/mp;
my $subst = '\\g<1>000\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";