import re
regex = re.compile(r"^(C3-)(\d)$", flags=re.MULTILINE)
test_str = "C3-1"
subst = "\\g<1>000\\2"
result = regex.sub(subst, test_str)
if result:
print(result)