#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\s*<div\s[^"]*\"[^"]*\">[\s\S]*<a[\s\S]*\/dp\/(.*?)\/"
Local $sString = "<div class="a-section a-spacing-mini">" & @CRLF & _
" ‹ <a href="https://www.amazon.com/New-Balance-WX577V4-Trainer-Heather/dp/B01FSIO7GQ/ref=olp_product_details?_encoding=UTF8&me=" id="olpDetailPageLink">Return to product information</a>" & @CRLF & _
" " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")