// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)\s*<div\s[^"]*\"[^"]*\">[\s\S]*<a[\s\S]*\/dp\/(.*?)\/"#).unwrap();
let string = "<div class=\"a-section a-spacing-mini\">
‹ <a href=\"https://www.amazon.com/New-Balance-WX577V4-Trainer-Heather/dp/B01FSIO7GQ/ref=olp_product_details?_encoding=UTF8&me=\" id=\"olpDetailPageLink\">Return to product information</a>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}