import Foundation
let pattern = #"\s*<div\s[^"]*\"[^"]*\">[\s\S]*<a[\s\S]*\/dp\/(.*?)\/"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<div class="a-section a-spacing-mini">
‹ <a href="https://www.amazon.com/New-Balance-WX577V4-Trainer-Heather/dp/B01FSIO7GQ/ref=olp_product_details?_encoding=UTF8&me=" id="olpDetailPageLink">Return to product information</a>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)