$re = '/\s*<div\s[^"]*\"[^"]*\">[\s\S]*<a[\s\S]*\/dp\/(.*?)\//m';
$str = '<div class="a-section a-spacing-mini">
‹ <a href="https://www.amazon.com/New-Balance-WX577V4-Trainer-Heather/dp/B01FSIO7GQ/ref=olp_product_details?_encoding=UTF8&me=" id="olpDetailPageLink">Return to product information</a>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);