import re
regex = re.compile(r"\s*<div\s[^\"]*\"[^\"]*\">[\s\S]*<a[\s\S]*\/dp\/(.*?)\/", flags=re.MULTILINE)
test_str = ("<div class=\"a-section a-spacing-mini\">\n"
" ‹ <a href=\"https://www.amazon.com/New-Balance-WX577V4-Trainer-Heather/dp/B01FSIO7GQ/ref=olp_product_details?_encoding=UTF8&me=\" id=\"olpDetailPageLink\">Return to product information</a>\n"
" \n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")