const regex = /<table\b[^\>]*\bname=(\"|')?table01\1[^\>]*>(?>([^\<]+|<(?!\/?table\b))|(<table[^\>]*>(?:(?2)|(?3)|)+?<\/table>))*<\/table>/ig;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<table\\b[^\\>]*\\bname=(\\"|\')?table01\\1[^\\>]*>(?>([^\\<]+|<(?!\\\/?table\\b))|(<table[^\\>]*>(?:(?2)|(?3)|)+?<\\\/table>))*<\\\/table>', 'ig')
const str = `<table name="table01" data-measure-unit="Y">
<table></table>
</table>
<table name="table01" data-measure-unit="Y">
<div>
<table></table>
</div>
</table>
<table name="table01" data-measure-unit="Y">
<div>
<table>
<table>
</table>
</table>
</div>
</table>
<table name="table01" data-measure-unit="Y">
<div>
<div></div>
</div>
</table>
<table name="table01" data-measure-unit="Y">
</table>
<table name="table01"></table>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}