import re
regex = re.compile(r"""
<table\b[^\>]*\bname=(\"|')?table01\1[^\>]*>(?>([^\<]+|<(?!\/?table\b))|(<table[^\>]*>(?:(?2)|(?3)|)+?<\/table>))*<\/table>
""", flags=re.IGNORECASE | re.VERBOSE)
test_str = ("<table name=\"table01\" data-measure-unit=\"Y\">\n"
" <table></table>\n"
"</table>\n\n"
"<table name=\"table01\" data-measure-unit=\"Y\">\n"
" <div>\n"
" <table></table>\n"
" </div>\n"
"</table>\n\n"
"<table name=\"table01\" data-measure-unit=\"Y\">\n"
" <div>\n"
" <table>\n"
" <table>\n"
" \n"
" </table>\n"
" </table>\n"
" </div>\n"
"</table>\n\n"
"<table name=\"table01\" data-measure-unit=\"Y\">\n"
" <div>\n"
" <div></div>\n"
" </div>\n"
"</table>\n\n"
"<table name=\"table01\" data-measure-unit=\"Y\">\n\n"
"</table>\n\n"
"<table name=\"table01\"></table>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")