use strict;
my $str = '<table name="table01" data-measure-unit="Y">
<table></table>
</table>
<table name="table01" data-measure-unit="Y">
<div>
<table></table>
</div>
</table>
<table name="table01" data-measure-unit="Y">
<div>
<table>
<table>
</table>
</table>
</div>
</table>
<table name="table01" data-measure-unit="Y">
<div>
<div></div>
</div>
</table>
<table name="table01" data-measure-unit="Y">
</table>
<table name="table01"></table>';
my $regex = qr/<table\b[^\>]*\bname=(\"|')?table01\1[^\>]*>(?>([^\<]+|<(?!\/?table\b))|(<table[^\>]*>(?:(?2)|(?3)|)+?<\/table>))*<\/table>/ixp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}