using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([^.]+)\_([^.]+)\_([^.]+)\_([^.]+)\_([^.]+)\.fastq$";
string substitution = @"$1_$4.fastq";
string input = @"A10_S65_L001_R1_001.fastq
A8_S49_L001_R2_001.fastq
B7_S42_L001_R1_001.fastq
C5_S27_L001_R2_001.fastq
F4_S22_L001_R1_001.fastq
G2_S7_L001_R2_001.fastq
H1_S165_L001_R1_001.fastq
A10_S65_L001_R2_001.fastq
A9_S57_L001_R1_001.fastq
B7_S42_L001_R2_001.fastq
C6_S35_L001_R1_001.fastq
F4_S22_L001_R2_001.fastq
G3_S15_L001_R1_001.fastq
H1_S165_L001_R2_001.fastq";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}