package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([^.]+)\_([^.]+)\_([^.]+)\_([^.]+)\_([^.]+)\.fastq$`)
var str = `A10_S65_L001_R1_001.fastq
A8_S49_L001_R2_001.fastq
B7_S42_L001_R1_001.fastq
C5_S27_L001_R2_001.fastq
F4_S22_L001_R1_001.fastq
G2_S7_L001_R2_001.fastq
H1_S165_L001_R1_001.fastq
A10_S65_L001_R2_001.fastq
A9_S57_L001_R1_001.fastq
B7_S42_L001_R2_001.fastq
C6_S35_L001_R1_001.fastq
F4_S22_L001_R2_001.fastq
G3_S15_L001_R1_001.fastq
H1_S165_L001_R2_001.fastq`
var substitution = "$1_$4.fastq"
fmt.Println(re.ReplaceAllString(str, substitution))
}