import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([^.]+)\\_([^.]+)\\_([^.]+)\\_([^.]+)\\_([^.]+)\\.fastq$";
final String string = "A10_S65_L001_R1_001.fastq\n"
+ "A8_S49_L001_R2_001.fastq\n"
+ "B7_S42_L001_R1_001.fastq\n"
+ "C5_S27_L001_R2_001.fastq\n"
+ "F4_S22_L001_R1_001.fastq\n"
+ "G2_S7_L001_R2_001.fastq\n"
+ "H1_S165_L001_R1_001.fastq\n"
+ "A10_S65_L001_R2_001.fastq\n"
+ "A9_S57_L001_R1_001.fastq\n"
+ "B7_S42_L001_R2_001.fastq\n"
+ "C6_S35_L001_R1_001.fastq\n"
+ "F4_S22_L001_R2_001.fastq\n"
+ "G3_S15_L001_R1_001.fastq\n"
+ "H1_S165_L001_R2_001.fastq";
final String subst = "$1_$4.fastq";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}