using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!>)([^><]+)(?=<\/h[0-9]>)";
string input = @"<h1 id=""--the-instagram-photo-feed""><img alt=""alt text"" src=""https://assets.breatheco.de/apis/img/images.php?blob&random&cat=icon&tags=breathecode,32"" class=""MDImg""> The Instagram Photo Feed</h1>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}