import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?!>)([^><]+)(?=<\\/h[0-9]>)";
final String string = "<h1 id=\"--the-instagram-photo-feed\"><img alt=\"alt text\" src=\"https://assets.breatheco.de/apis/img/images.php?blob&random&cat=icon&tags=breathecode,32\" class=\"MDImg\"> The Instagram Photo Feed</h1>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}