const regex = /(?!>)([^><]+)(?=<\/h[0-9]>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?!>)([^><]+)(?=<\\\/h[0-9]>)', 'gm')
const str = `<h1 id="--the-instagram-photo-feed"><img alt="alt text" src="https://assets.breatheco.de/apis/img/images.php?blob&random&cat=icon&tags=breathecode,32" class="MDImg"> The Instagram Photo Feed</h1>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}