$re = '/(?!>)([^><]+)(?=<\/h[0-9]>)/m';
$str = '<h1 id="--the-instagram-photo-feed"><img alt="alt text" src="https://assets.breatheco.de/apis/img/images.php?blob&random&cat=icon&tags=breathecode,32" class="MDImg"> The Instagram Photo Feed</h1>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);