package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`href="([^"]+)`)
var str = `<a href="url"></a><a href="url2"></a><a href="url3"></a>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}