re = /href="([^"]+)/
str = '<a href="url"></a><a href="url2"></a><a href="url3"></a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end