const regex = /href="([^"]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('href="([^"]+)', 'g')
const str = `<a href="url"></a><a href="url2"></a><a href="url3"></a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}