import re
regex = re.compile(r"href=\"([^\"]+)")
test_str = "<a href=\"url\"></a><a href=\"url2\"></a><a href=\"url3\"></a>"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")