$re = '/href="([^"]+)/';
$str = '<a href="url"></a><a href="url2"></a><a href="url3"></a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);