# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.*?((?(?=.*?(\b(?:broadway|acme)\b).*?)\2|.*)).*?$/$1/gim;t' <<< "ACME Corp 123
Corp 742 ACME
Some ACME some
Random Text
Broadway 1785 FB"