import Foundation
let pattern = #"^.*?((?(?=.*?(\b(?:broadway|acme)\b).*?)\2|.*)).*?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
ACME Corp 123
Corp 742 ACME
Some ACME some
Random Text
Broadway 1785 FB
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)